Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delay in delivery of MMS messages
      Incident Report for Twilio
      Resolved
      Delivery of MMS messages in US/CA has been restored and operating normally at this time.
      Posted Nov 29, 2016 - 13:14 PST
      Update
      Our carrier partner is still actively working to resolve the issue, there is no ETA at this time.
      Posted Nov 29, 2016 - 12:01 PST
      Update
      Our partner has identified the problem, they are actively working to resolve. We expect delivery delays via long codes for all USA and Canadian numbers.
      Posted Nov 29, 2016 - 11:24 PST
      Identified
      The issue has been identified and a fix is being implemented.
      Posted Nov 29, 2016 - 11:20 PST
      Investigating
      Delay in delivery of MMS messages: MMS messages for inbound and outbound requests are delayed. There is no impact to SMS delivery or Short code MMS delivery. This affects all operators in the US & CA.
      Posted Nov 29, 2016 - 11:04 PST
      This incident affected: PROGRAMMABLE MESSAGING (MMS).