Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
A small subset of newly created accounts are unable to send or receive calls and messages
Incident Report for Twilio
Resolved
We have determined that accounts created between 18:31 - 18:41 UTC were able to send and receive calls and messages. We apologize for the confusion. All services were and remain fully operational.
Posted May 19, 2020 - 13:18 PDT
Update
A small subset of newly created accounts (created between 18:31 - 18:41 UTC) remain unable to send or receive calls and messages. Our engineers are working to restore service and we will provide an update as quickly as possible.
Posted May 19, 2020 - 12:55 PDT
Update
A small subset of newly created accounts (created between 18:31 - 18:41 UTC) are unable to send or receive calls and messages. Our engineers are working to restore service and we will provide an update as quickly as possible.
Posted May 19, 2020 - 12:36 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted May 19, 2020 - 12:15 PDT
This incident affected: TWILIO PLATFORM (Other).