Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Somalia
      Incident Report for Twilio
      Resolved
      The issue with SMS delivery delays when sending messages to Somalia has been resolved. The service is functioning normally at this time.
      Posted Jul 30, 2022 - 22:01 PDT
      Update
      We are still experiencing SMS delivery delays when sending messages to Somalia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Jul 30, 2022 - 14:06 PDT
      Update
      We are still experiencing SMS delivery delays when sending messages to Somalia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
      Posted Jul 29, 2022 - 22:06 PDT
      Update
      We are still experiencing SMS delivery delays when sending messages to Somalia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Jul 29, 2022 - 14:06 PDT
      Update
      We are experiencing SMS delivery delays when sending messages to Somalia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Jul 29, 2022 - 10:08 PDT
      Update
      We are experiencing SMS delivery delays when sending messages to Somalia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jul 29, 2022 - 08:08 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to Somalia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jul 29, 2022 - 07:08 PDT
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).