Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delayed data on /messages API
      Incident Report for Twilio
      Resolved
      The engineering team has completed the backfilling of messages effected by the incident. At this point, the /messages API is operating normally.
      Posted Nov 08, 2016 - 23:43 PST
      Update
      The engineering team is starting the message backfill at 17:10 PST. This backfill operation will process messages for all incident windows observed today: 09:50 - 11:10, 12:50 - 13:35, and 14:00 - 14:45 PST. We are continuing to monitor the system.
      Posted Nov 08, 2016 - 17:05 PST
      Update
      The system has recovered and messages are available through the /Messages API without delays. The engineering team is planning to start backfilling messages for all incident windows after 5pm PST. We are continuing to monitor the system.
      Posted Nov 08, 2016 - 14:43 PST
      Update
      We are observing delays in message information being available through the /Messages API. Our engineering team is actively working on resolving the issue. We will provide another update in 1hr.
      Posted Nov 08, 2016 - 14:20 PST
      Update
      The system has recovered and messages are available through the /Messages API without delays. The engineering team is working on backfilling messages for the incident windows of 10:00 to 11:00 and 12:59 to 13:25 PST. We are continuing to monitor the system.
      Posted Nov 08, 2016 - 13:33 PST
      Update
      We are observing delays in message information being available through the /Messages API. Our engineering team is actively working on resolving the issue. We will provide another update in 1hr.
      Posted Nov 08, 2016 - 13:14 PST
      Monitoring
      The system has recovered and message data should be available through the /messages API without delays. The engineering team is continuing to monitor the system. Messages that were affected by the incident will be backfilled over the next few hours.
      Posted Nov 08, 2016 - 11:10 PST
      Investigating
      Starting at 10am PST this morning, we are experiencing the delays in message data being available through the /Messages API. The engineering team is investigating the issue and will provide an update within 1 hour. Incoming and outgoing message processing is not affected.
      Posted Nov 08, 2016 - 10:12 PST
      This incident affected: DEVELOPER TOOLS (REST API).