Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Billing Issues Due to Ongoing Network Latencies
Incident Report for Twilio
Resolved
This issue has been resolved. We have mitigated the impact from the service disruption with the exception of a small percentage of customers. These customers will be handled on a case by case basis by our support team.
Posted Nov 26, 2020 - 18:00 PST
Update
Twilio’s network provider has identified the root cause of the service disruption resulting in payment processing issues for trial accounts and upgraded accounts. Our engineering team is actively working with them to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
Posted Nov 26, 2020 - 00:59 PST
Identified
Twilio’s network provider has identified the root cause of the service disruption resulting in payment processing issues for trial accounts and upgraded accounts. Our engineering team is actively working with them to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Nov 25, 2020 - 17:01 PST
Update
Due to ongoing network latencies, we continue experiencing payment processing issues affecting trial accounts and upgraded accounts. Our engineering team is actively working on the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Nov 25, 2020 - 13:04 PST
Update
Due to the network latency issues, we are experiencing payment processing issues affecting trial accounts and upgraded accounts. Our engineering team is actively working on the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 25, 2020 - 11:05 PST
Update
We are continuing to investigate issues with trial accounts not upgrading after completing the payment. Our engineering team is actively looking into the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 25, 2020 - 10:01 PST
Update
We are continuing to investigate issues with trial accounts not upgrading after completing the payment. Our engineering team is looking into the issue. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Nov 25, 2020 - 09:31 PST
Investigating
We are currently investigating issues with trial accounts not upgrading after completing the payment. Our engineering team is looking into the issue. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Nov 25, 2020 - 09:01 PST
This incident affected: TWILIO PLATFORM (Billing).