Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound calls failing to a subset of Twilio phone numbers in the US
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 25 days ago. Sep 25, 2019 - 15:34 PDT
Monitoring
We’ve fixed the issue with receiving inbound calls to a subset of Twilio phone numbers in the US. We have seen recovery for all of the affected phone numbers. We will monitor them for a while to ensure that the recovery is sustained. We will provide further updates as we gain more information.
Posted 25 days ago. Sep 25, 2019 - 14:29 PDT
Update
We continue to work with our carrier partner on the issue receiving inbound calls to a subset of Twilio phone numbers in the US. We have seen recovery for the majority of the affected phone numbers, and continue to work on the remaining ones. We will provide further updates as we gain more information.
Posted 25 days ago. Sep 25, 2019 - 13:23 PDT
Update
We have identified the root cause of the issue receiving inbound calls to a subset of Twilio phone numbers in the US. We are working with our carrier partners to resolve the issue. We have seen recovery for approximately a third of the affected phone numbers, and continue to work on the rest. We will provide further updates as we gain more information.
Posted 25 days ago. Sep 25, 2019 - 10:30 PDT
Identified
We have detected an issue receiving inbound calls to a subset of Twilio phone numbers in the US. We are working with our carrier partners to resolve the issue, we will provide periodic updates as we gain more information.
Posted 25 days ago. Sep 25, 2019 - 08:46 PDT
This incident affected: CARRIER NETWORK (Voice, North America).