Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delay to Google Voice in the USA
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery delays to Google Voice numbers in the US. This incident has been resolved.
      Posted Jul 07, 2020 - 00:24 PDT
      Monitoring
      We are observing improvements in SMS delivery times towards Google Voice numbers in the US. We will continue to monitor to ensure a full recovery.
      Posted Jul 06, 2020 - 21:58 PDT
      Update
      We are still experiencing SMS delivery delay for subset of SMS shortcode submitted to Google Voice in the USA. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Jul 06, 2020 - 20:24 PDT
      Investigating
      We are experiencing delivery delay for subset of SMS shortcode submitted to Google Voice in the USA. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Jul 06, 2020 - 19:19 PDT
      This incident affected: CARRIER NETWORK (SMS Long Code, North America, SMS Short Code, North America).