Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS not being delivered to Movistar Mexico
Incident Report for Twilio
Resolved
Non Delivery towards Movistar Mexico has been resolved and SMS is operating normally at this time.
Posted 3 months ago. Jan 29, 2019 - 14:24 PST
Monitoring
Our carrier partners have confirmed that the issue has been fully restored. We are continuing to monitor to verify.
Posted 3 months ago. Jan 29, 2019 - 12:20 PST
Identified
We are have identified non-delivery of SMS for a subset of customers in Mexico on the Movistar network. We are working with our carrier partners to resolve the issue.
Posted 3 months ago. Jan 29, 2019 - 11:11 PST
This incident affected: CARRIER NETWORK (SMS Long Code, North America).