Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Platform Delays Impacting Multiple Services
Incident Report for Twilio
Resolved
Between 05:22 and 08:55 Pacific Time, Twilio experienced data processing delays impacting the Flex queue dashboard as well as Flex Insights. Customers may also experience delays in voice call record deletion and messaging callback delivery. The service started to recover around 7:30am Pacific Time, with full recovery around 8:55 Pacific Time. The incident is now resolved.
Posted Jul 23, 2021 - 10:35 PDT
Monitoring
We have identified additional products affected, below is the list of affected components
Flex Insights: Queue stats dashboard
Programmable Voice: Delay in deleting call record via API, Voice Insight in Conference Insight
Programmable Messaging: Callback delivery delay
We have seen recovery for for these components and we will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 23, 2021 - 08:34 PDT
Update
We are investigating task operation delays in the queue stats dashboard for a subset of customers. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 23, 2021 - 07:30 PDT
Update
We are investigating task operation delays in the queue stats dashboard a subset of customers. We expect to provide another update in 1 hour or as soon as more information becomes available
Posted Jul 23, 2021 - 06:31 PDT
Investigating
Our monitoring systems have detected a potential issue with Flex Insights. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 23, 2021 - 06:22 PDT
This incident affected: FLEX (TaskRouter, Flex Insights), DEVELOPER TOOLS (REST API), PROGRAMMABLE VOICE (Voice Insights), and PROGRAMMABLE MESSAGING (Notify).