Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Subset of Call Data Not Deleted
      Incident Report for Twilio
      Resolved
      We are no longer experiencing the problem with call data not deleted when requested via the API. Service has been restored and call DELETE REST API requests between 14 Jan 2021 3:14:00 AM PST - 8:45:00 AM PST have been completed and are up to date.
      Posted Jan 14, 2021 - 09:23 PST
      Monitoring
      Our engineering team has identified the call data that was not deleted when initially requested. The service has been restored. Call DELETE REST API requests between 14 Jan 2021 3:14:00 AM PST - 8:45:00 AM PST have been completed and are up to date. Our engineers will continue to monitor for system stability. We will provide another update in 60 minutes or as soon as more information becomes available.
      Posted Jan 14, 2021 - 08:58 PST
      Identified
      We are addressing an issue with a subset of customer call data that was not deleted. API requests to delete call data between 14 Jan 2021 3:14:00 AM PST - 6:12:00 AM PST have not resulted in the call data deletion. Our engineering team has been alerted and is actively investigating. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 14, 2021 - 08:02 PST
      This incident affected: DEVELOPER TOOLS (REST API).