We are no longer experiencing issues with Automatic Account Reactivations following successful payments. This incident has been resolved.
Posted Mar 26, 2026 - 04:37 PDT
Update
We have observed a recovery in the issue where customer accounts were not automatically reactivating after a successful payment. We are now monitoring service stability to ensure a full recovery. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Mar 26, 2026 - 04:02 PDT
Monitoring
We have observed a recovery in the issue where customer accounts were not automatically reactivating after a successful payment. We are now monitoring service stability to ensure a full recovery. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Mar 26, 2026 - 03:31 PDT
Update
The issue causing the customer accounts to not automatically reactivate after a successful payment has been identified. We are actively working to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Mar 26, 2026 - 01:57 PDT
Update
The issue causing the customer accounts to not automatically reactivate after a successful payment has been identified. We are actively working to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Mar 25, 2026 - 21:39 PDT
Update
The issue causing the customer accounts to not automatically reactivate after a successful payment has been identified. We are actively working to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 25, 2026 - 19:43 PDT
Identified
The issue causing the customer accounts to not automatically reactivate after a successful payment has been identified. We are actively working to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 25, 2026 - 18:45 PDT
Update
We continue investigating reports of customer accounts not automatically reactivating after a successful payment. We will provide another update in 4 hours or as soon as more information is available.
Posted Mar 25, 2026 - 18:33 PDT
Update
We continue investigating reports of customer accounts not automatically reactivating after a successful payment. We will provide another update in 2 hours or as soon as more information is available.
Posted Mar 25, 2026 - 16:34 PDT
Update
We are investigating reports of customer accounts not automatically reactivating after a successful payment. We will provide another update in 1 hour or as soon as more information is available.
Posted Mar 25, 2026 - 15:41 PDT
Investigating
Twilio users who have a positive account balance are not being automatically reactivated and are reporting to Support.
Posted Mar 25, 2026 - 15:17 PDT
This incident affected: TWILIO PLATFORM (Billing).