Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Super SIM Network Connectivity Issues
Incident Report for Twilio
Resolved
We are no longer experiencing Super SIM connectivity issues issue. The incident has been resolved
Posted Oct 08, 2020 - 17:09 PDT
Monitoring
We experienced Super SIM connectivity issues starting 20:15 UTC with one of our connectivity partners.
We are seeing recovery since 22:40 UTC. Our engineering team is monitoring the situation and will update in 1 hour or as soon as new information is available.
Posted Oct 08, 2020 - 15:48 PDT
Investigating
Our monitoring systems have detected a potential issue with Super SIM Connectivity. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 08, 2020 - 15:27 PDT
This incident affected: INTERNET OF THINGS (Super SIM).