Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays and Queueing
      Incident Report for Twilio
      Resolved
      All our internal queues for SMS have cleared up (besides specific customers that we have reached out too) and we should not be seeing any further delays. As such, unless we have reached out, you should not be seeing any further delays.
      Posted Nov 27, 2020 - 10:11 PST
      Update
      We continue to experience SMS delivery delays and queuing. Our engineers are investigating. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 27, 2020 - 09:31 PST
      Investigating
      We are experiencing SMS delivery delays and queuing. Our engineers are investigating. We will provide another update in 30 minutes or as soon as more information becomes available.
      Posted Nov 27, 2020 - 09:01 PST
      This incident affected: PROGRAMMABLE MESSAGING (SMS).