Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Delays on US Short Codes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing MMS delivery delays to US AT&T from a small subset of US short codes. This incident has been resolved.
      Posted Oct 15, 2020 - 17:49 PDT
      Monitoring
      We are observing successful MMS delivery to US AT&T from a small subset of US short codes for the last 30 minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Oct 15, 2020 - 17:12 PDT
      Update
      We are continuing to experience MMS delivery delays to US AT&T for a small subset of US short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
      Posted Oct 15, 2020 - 10:05 PDT
      Update
      We are continuing to experience MMS delivery delays to US AT&T, Verizon, and Sprint for a small subset of US short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
      Posted Oct 15, 2020 - 02:55 PDT
      Update
      We are continuing to experience MMS delivery delays to US AT&T, Verizon, and Sprint for a small subset of US short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
      Posted Oct 14, 2020 - 18:29 PDT
      Update
      We are continuing to experience MMS delivery delays to US AT&T, Verizon, and Sprint for a small subset of US short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Oct 14, 2020 - 14:38 PDT
      Update
      We are continuing to experience MMS delivery delays to US AT&T, Verizon, and Sprint for a small subset of US short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Oct 14, 2020 - 12:30 PDT
      Update
      We are experiencing MMS delivery delays to US AT&T, Verizon, and Sprint for a small subset of US short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Oct 14, 2020 - 11:31 PDT
      Investigating
      We are experiencing MMS delivery delays to US AT&T for a small subset of US short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Oct 14, 2020 - 11:01 PDT
      This incident affected: CARRIER NETWORK (MMS Short Code, North America).