Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Vodafone Egypt
      Incident Report for Twilio
      Resolved
      This incident has been resolved. All services are operating normally.
      Posted May 18, 2020 - 03:21 PDT
      Monitoring
      We are observing recovery in SMS delivery to Vodafone network in Egypt. We will continue to monitor this situation and will provide an update as soon as more information becomes available.
      Posted May 18, 2020 - 02:24 PDT
      Update
      Our engineers are still investigating this issue with the underlying carrier. We will provide more updates as soon as we receive them.
      Posted May 17, 2020 - 23:59 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to Vodafone in Egypt. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted May 17, 2020 - 23:07 PDT