Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delivery Status Delays To Indosat Indonesia
Incident Report for Twilio
Resolved
We are no longer experiencing delays on delivery status of international messages to Indosat Indonesia. This incident has been resolved.
Posted May 14, 2020 - 11:52 PDT
Update
The delays on delivery status of international messages to Indosat Indonesia is still ongoing. Our engineers are working with our carrier partners to resolve the issue as soon as possible and will provide an update as soon as we have more information
Posted May 14, 2020 - 08:17 PDT
Update
We are continuing to investigate this issue.
Posted May 14, 2020 - 04:35 PDT
Update
We are continuing to investigate this issue.
Posted May 14, 2020 - 01:38 PDT
Update
The delays on delivery status of international messages to Indosat Indonesia is still ongoing. Further investigation shows that it is now also impacting local Indonesia traffic. Our engineers are working with our carrier partners to resolve the issue as soon as possible and will provide an update as soon as we have more information
Posted May 13, 2020 - 22:11 PDT
Update
The delays on delivery status of international messages to the Indosat network in Indonesia is still ongoing.
Posted May 13, 2020 - 20:44 PDT
Investigating
We are observing delays in receiving delivery status of international messages to the Indosat network in Indonesia. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information
Posted May 13, 2020 - 19:52 PDT
This incident affected: CARRIER NETWORK (SMS, APAC).