Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Report Delays when Sending to Indonesia XL Axiata
Incident Report for Twilio
Resolved
We are no longer experiencing delivery report delays when sending SMS to Indonesia XL Axiata. This incident has been resolved.
Posted Feb 21, 2021 - 11:29 PST
Monitoring
We are observing recovery in delivery report delays when sending SMS to Indonesia XL Axiata. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 21, 2021 - 10:50 PST
Update
We are continuing to experience delays in receiving message delivery reports when sending SMS to Indonesia XL Axiata. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 21, 2021 - 09:00 PST
Investigating
We are experiencing delays in receiving message delivery reports when sending to Indonesia XL Axiata. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 60 minutes or as soon as more information becomes available.
Posted Feb 21, 2021 - 08:02 PST
This incident affected: CARRIER NETWORK (SMS Delivery Notifications & Status Callbacks).