Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS and Calls Overcharges for UK Numbers
      Incident Report for Twilio
      Resolved
      The process of overcharging for some UK calls and sms has been resolved, and the service is functioning normally at this time. We are continuing the process of crediting back the overcharges.
      Posted Sep 27, 2021 - 15:16 PDT
      Monitoring
      The process of overcharging for some UK calls and sms is now corrected and operating as normal. We are in the process of crediting back the overcharges. We’ll provide another update in 60 minutes or as soon as more information becomes available.
      Posted Sep 27, 2021 - 14:02 PDT
      Update
      Our engineers have identified the issue that caused overcharges for some UK calls and sms. Between 12:10am PST to 12:15am PST customers using British Pound as their currency may have been overcharged. We will provide another update in 4 hours or as more information becomes available.
      Posted Sep 27, 2021 - 09:55 PDT
      Identified
      Our engineers have identified the issue that caused overcharges for some UK calls and sms. Between 12:10am PST to 12:15am PST customers using British Pound as their currency may have been overcharged. We will provide another update in 2 hours or as more information becomes available.
      Posted Sep 27, 2021 - 07:55 PDT
      Update
      We are still experiencing SMS and Calls overcharges for some UK Numbers. Our engineers are working to resolve the issue. We will provide an update in 1 hour or as soon as more information becomes available.
      Posted Sep 27, 2021 - 06:55 PDT
      Update
      We are experiencing SMS and Calls overcharges for some UK Numbers. Our engineers are working to resolve the issue. We will provide an update in 30 minutes or as soon as more information becomes available.
      Posted Sep 27, 2021 - 06:25 PDT
      Investigating
      Our monitoring systems have detected a potential issue with Programmable SMS and Programmable Voice Billing in the UK. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 27, 2021 - 06:19 PDT
      This incident affected: TWILIO PLATFORM (Billing).