Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Failures on Movilnet in Venezuela
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery failures to Venezuela Movilnet. This incident has been resolved.
      Posted Jun 18, 2020 - 01:26 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
      Posted Jun 17, 2020 - 23:04 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
      Posted Jun 17, 2020 - 15:56 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
      Posted Jun 17, 2020 - 08:14 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
      Posted Jun 17, 2020 - 04:06 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
      Posted Jun 17, 2020 - 01:52 PDT
      Investigating
      We are experiencing delivery failures sending to Venezuela Movilnet. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Jun 17, 2020 - 00:52 PDT
      This incident affected: CARRIER NETWORK (SMS, Latin America).