Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays in sending and receiving messages for US Toll Free numbers
Incident Report for Twilio
Resolved
Twilio services are fully operational New MT and MO messages on toll-free phone numbers have returned to real time. A small percentage of messages during the incident may still be processing on the carrier side but will deliver.
Posted 9 months ago. Apr 25, 2018 - 20:20 PDT
Monitoring
We are observing recovery. Queued messages are being processed. We will post an update when delivery has been fully recovered.
Posted 9 months ago. Apr 25, 2018 - 16:55 PDT
Investigating
We have detected delays for sending and receiving messages for US Toll Free numbers. Sending messages to regular numbers is not affected and operating normally. We have escalated to the carrier and they are actively working to resolve the issue.
Posted 9 months ago. Apr 25, 2018 - 16:20 PDT
This incident affected: PROGRAMMABLE MESSAGING (SMS).