Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Report Delays To NetOne Zimbabwe
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delays in receiving delivery reports for SMS sent to NetOne Zimbabwe. This incident has been resolved.
      Posted Mar 28, 2020 - 13:15 PDT
      Monitoring
      We are seeing signs of recovery for Delivery Reports to NetOne Zimbabwe. We will continue to monitor to ensure a full recovery.
      Posted Mar 28, 2020 - 12:22 PDT
      Update
      Our engineers are still investigating this issue with the underlying carrier. We will provide more updates as soon as they become available.
      Posted Mar 28, 2020 - 10:33 PDT
      Update
      We are observing delays in receiving delivery reports for SMS sent to NetOne Zimbabwe. We are working with our carrier partners to resolve the issue and will provide further updates as soon as they become available.
      Posted Mar 28, 2020 - 09:51 PDT
      Investigating
      Our monitoring systems have detected a potential issue with Delivery Reports to NetOne Zimbabwe. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Mar 28, 2020 - 09:50 PDT