Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Issues to Orange Mobinil Egypt handsets
Incident Report for Twilio
Resolved
Delivery rate performance has been stable from past 30 minutes. Our internal testing also showed messages and its delivery reports were delivered in a timely manner.
Posted 15 days ago. Apr 09, 2019 - 20:00 PDT
Investigating
We are experiencing delivery issues of SMS sent to Orange Mobinil Egypt handsets. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted 15 days ago. Apr 09, 2019 - 18:35 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).