Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery receipts delayed from Toll Free numbers to the Verizon Network in US
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 17, 2019 - 04:55 PST
Monitoring
Carrier maintenance is now complete and both SMS delivery and delivery receipts are operating as normal for all number types and all destination networks. We continue to monitor the situation.
Posted 3 months ago. Feb 17, 2019 - 04:19 PST
Investigating
Extended carrier maintenance is resulting in delays to SMS delivery receipts when sending from Toll Free numbers to the Verizon network in US. Message delivery appears to be unaffected. All other number types and networks unaffected. We continue to work with our partners on a resolution. We will provide an update when we have further information.
Posted 3 months ago. Feb 17, 2019 - 01:03 PST
This incident affected: CARRIER NETWORK (SMS Long Code, North America).