Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to US T-Mobile From a Subset of Twilio Shortcodes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery delays to US T-Mobile from a subset of Twilio shortcodes. This incident has been resolved.
      Posted Jan 23, 2021 - 02:04 PST
      Monitoring
      We are observing successful SMS delivery to US T-Mobile from Twilio shortcodes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 23, 2021 - 00:26 PST
      Update
      We are still experiencing SMS delivery delays to US T-Mobile from a subset of Twilio shortcodes. We are working with our carrier partners to resolve this issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
      Posted Jan 22, 2021 - 23:56 PST
      Update
      We are still experiencing SMS delivery delays to US T-Mobile from a subset of Twilio shortcodes. We are working with our carrier partners to resolve this issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
      Posted Jan 22, 2021 - 16:01 PST
      Update
      We are continuing to work with our carrier partners to resolve this issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Jan 22, 2021 - 12:37 PST
      Update
      We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 22, 2021 - 10:42 PST
      Update
      We are experiencing SMS delivery delays to US T-Mobile from a subset of Twilio shortcodes. We are working with our carrier partners to resolve this issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 22, 2021 - 09:42 PST
      Investigating
      Our monitoring systems have detected a potential issue with SMS delivery delays to US T-Mobile from a subset of Twilio shortcodes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jan 22, 2021 - 09:11 PST
      This incident affected: CARRIER NETWORK (SMS Short Code, North America).