Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Google Chrome v73.0.3683.103 upgrade causing TaskRouter v1.19 Failures
Incident Report for Twilio
Resolved
We have distributed a TaskRouter v1 SDK / Google Chrome v73.0.3683.103 advisory to all impacted customers. We will be following up with additional guidance on solutions to the synchronous XHR issues caused by the Chrome update. As a reminder, v2 of the TaskRouter SDK is not impacted.
Posted 8 days ago. Apr 16, 2019 - 16:23 PDT
Identified
We have identified multiple options for avoiding or alleviating errors in the v1 TaskRouter SDK caused by changes made in the latest Google Chrome update (v73.0.3683.103) We will be sending an advisory to all affected customers. This issue does not impact the V2 SDK nor Flex. We will leave this notice up until the advisory has been delivered.
Posted 9 days ago. Apr 15, 2019 - 23:27 PDT
Investigating
The latest Google Chrome update (v73.0.3683.103) has removed synchronous XMLHttpRequest (XHR), which is resulting in V1 TaskRouter SDK agent offline setting failures. V1 SDK Customers are advised to avoid the Chrome upgrade until our engineers have a patch to eliminate the failures. Customers that have already upgraded are advised to revert to an older version of Chrome. This issue does not impact TaskRouter V2 SDK, nor Flex customers.

We will provide an update as soon as we have additional information and an ETA for delivering a patch.
Posted 9 days ago. Apr 15, 2019 - 11:05 PDT