Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        5xx's in the Twilio Programmable Messaging API Responses

        Incident Report for Twilio

        Resolved

        The Twilio Programmable Messaging API was partially degraded for 2 minutes on 05/22/2025 between 14:00:40 PST and 14:01:30 PST. During this period of time, customers sending a message may have received elevated volumes of 5xx's in API responses. This issue has now been resolved.
        Posted May 22, 2025 - 15:08 PDT

        Monitoring

        Our engineers are currently investigating the customer impact of a retroactive issue with the Twilio Programmable Messaging API. We will follow up and provide customer impact details within 2 hours.
        Posted May 22, 2025 - 14:36 PDT