The issue affecting Voice quality to Twilio New Zealand phone numbers has been fixed.
Posted Nov 10, 2025 - 10:52 PST
Monitoring
We have started seeing recovery for Voice quality to Twilio New Zealand phone numbers. We will continue to monitor to ensure a full recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 10, 2025 - 09:51 PST
Investigating
We continue investigating an issue with Voice quality to a subset of Twilio New Zealand phone numbers, although we have started seeing recovery. We expect to provide another update in 2 hours or as soon as more information becomes available
Posted Nov 10, 2025 - 07:45 PST
Update
We have started seeing recovery for Voice quality to Twilio New Zealand phone numbers. We will continue to monitor to ensure a full recovery. We expect to provide another update in one hour or as soon as more information becomes available.
Posted Nov 10, 2025 - 05:50 PST
Monitoring
We have started seeing recovery for Voice quality to Twilio New Zealand phone numbers. We will continue to monitor to ensure a full recovery. We expect to provide another update in one hour or as soon as more information becomes available.
Posted Nov 10, 2025 - 04:57 PST
Investigating
We are investigating an issue with Voice quality to a subset of Twilio New Zealand phone numbers. We expect to provide another update in 1 hour or as soon as more information becomes available
Posted Nov 10, 2025 - 04:50 PST
This incident affected: CARRIER NETWORK (Voice, APAC).