Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Elevated 5xx Errors from Taskrouter

        Incident Report for Twilio

        Resolved

        This incident has been resolved.
        Posted Mar 31, 2025 - 05:23 PDT

        Update

        Twilio Taskrouter was degraded for 2 minutes between 05:00 and 05:02 Pacific Time on 03/31/2025. During this period of time, customers may have experienced 5xx errors. The issue has now been resolved.
        Posted Mar 31, 2025 - 05:21 PDT

        Monitoring

        Our engineers are currently investigating the customer impact of a retroactive issue with Programmable API. We will follow up and provide customer impact details within 2 hours.
        Posted Mar 31, 2025 - 05:13 PDT
        This incident affected: FLEX (TaskRouter).