Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Flex Queues Issue
Incident Report for Twilio
Resolved
The issue with Flex Queues has been resolved, and Flex is operating normally at this time.
Posted Oct 13, 2020 - 09:55 PDT
Update
We have identified a manual fix for the Flex Queues issue. Please contact the Support team for further assistance implementing this fix. We will update again in 16 hours or when we have more information.
Posted Oct 12, 2020 - 17:55 PDT
Update
We have identified a manual fix for the Flex Queues issue. Please contact the Support team for further assistance implementing this fix. We will update again in 8 hours or when we have more information.
Posted Oct 12, 2020 - 10:03 PDT
Update
We are continuing to work on a resolution for this issue. We will update again in 4 hours or when we have more information.

We have meanwhile identified a manual fix for the issue. Please contact the Support team for further assistance implementing this fix.
Posted Oct 12, 2020 - 06:04 PDT
Update
We are currently experiencing an issue with Queues in Flex. This affects placing Outbound Calls and transferring Calls to TaskQueues. This issue also manifests in TeamsView where some workers are not visible in the list due to this incident.

We have identified a manual fix for the issue. Please contact the Support team for further assistance implementing this fix.
Posted Oct 12, 2020 - 04:10 PDT
Identified
We are addressing the issue affecting Flex users. We expect to provide another update in 1 hour.
Posted Oct 12, 2020 - 03:25 PDT
Update
We are experiencing an issue wherein a subset of customers using the Flex Outbound Dialpad are unable to make outbound calls. We will provide another update in 30 minutes
Posted Oct 12, 2020 - 02:54 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 12, 2020 - 02:24 PDT
This incident affected: FLEX (Flex Application Platform).