Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Hot Mobile in Israel
Incident Report for Twilio
Resolved
We are no longer experiencing delivery delays on Hot Mobile network in Israel. This incident has been resolved.
Posted Feb 27, 2020 - 08:50 PST
Update
Our engineers are still investigating this issue with the underlying carrier. We will share more updates as soon as they become available.
Posted Feb 27, 2020 - 05:02 PST
Update
Our engineers are still investigating this issue with the underlying carrier. We will share more updates as soon as they become available.
Posted Feb 27, 2020 - 02:50 PST
Investigating
We are experiencing SMS delivery delays when sending messages to Hot Mobile network in Israel. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Feb 27, 2020 - 01:47 PST
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).