Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Delays From Twilio Long-Codes to US Carriers
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Nov 25, 2022 - 17:54 PST
      Monitoring
      Please find the current MMS delivery status from Twilio Long-Codes for the major carriers below:

      AT&T (status - Operational)
      T-Mobile (status - Operational)
      Sprint (status - Operational)
      Verizon (status - Operational)
      MetroPCS (status - Operational)
      US Cellular (status - Operational)

      We will provide another update in 2 hours or as soon as we have any new information to share.
      Posted Nov 25, 2022 - 15:22 PST
      Update
      Please find the current MMS delivery status from Twilio Long-Codes for the major carriers below:

      AT&T (status - Operational)
      T-Mobile (status - Delayed)
      Sprint (status - Delayed)
      Verizon (status - Operational)
      MetroPCS (status - Delayed)
      US Cellular (status - Operational)

      We will provide another update in 2 hours or as soon as we have any new information to share.
      Posted Nov 25, 2022 - 13:52 PST
      Update
      Due to sustained high traffic on the US carrier networks, we continue experiencing MMS delivery delays from Twilio long-codes. Messages are queued due to capacity shortage, and customers may see delays when sending to certain US carriers. Please find the current delivery status for the major carriers below:

      AT&T (status - Operational)
      T-Mobile (status - Delayed)
      Sprint (status - Delayed)
      Verizon (status - Operational)
      MetroPCS (status - Delayed)

      We are actively working with our carrier partners to resolve the issue, and we will provide another update in 2 hours or as soon as we have any new information to share.
      Posted Nov 25, 2022 - 11:34 PST
      Investigating
      Due to sustained high traffic on the US carrier networks, we are currently experiencing MMS delivery delays from Twilio long-codes. Messages are queued due to capacity shortage, and customers may see delays when sending to certain US carriers. Please find the current delivery status for the major carriers below:

      AT&T (status - Operational)
      T-Mobile (status - Delayed)
      Sprint (status - Delayed)
      Verizon (status - Operational)
      MetroPCS (status - Delayed)

      We are actively working with our carrier partners to resolve the issue, and we will provide another update in 2 hours or as soon as we have any new information to share.
      Posted Nov 25, 2022 - 09:37 PST
      This incident affected: CARRIER NETWORK (MMS Long Code, North America).