Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Calls failing to some Singapore numbers
Incident Report for Twilio
Resolved
The impacted numbers are again working and our carrier partner has confirmed that the issue has been resolved.
Posted 15 days ago. Mar 09, 2019 - 10:42 PST
Investigating
We have detected incoming call failures to some phone numbers in Singapore. We are working with our carrier partner on a resolution.
Posted 15 days ago. Mar 09, 2019 - 09:42 PST
This incident affected: CARRIER NETWORK (Voice, APAC).