Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      API errors querying for Message Logs
      Incident Report for Twilio
      Resolved
      All services are operating normally at this time.
      Posted Oct 28, 2016 - 13:16 PDT
      Monitoring
      We identified and resolved the problem that caused sporadic HTTP 404 errors between 7:00am PT and 11:25am PT. The current impact are HTTP 404 errors when querying for messages that were created between 11:00am PT and 11:25am PT today. Our engineers are resolving the issue for those specific messages, and we are monitoring the system for any recurrence.
      Posted Oct 28, 2016 - 12:29 PDT
      Update
      Messages created between 11:00am PT and 11:25am PT may return an HTTP 404 error when querying via the /Messages API resource. Messages created outside that time window, including all new Messages, are correctly returning HTTP 200. Incoming and outgoing message processing is not affected. Our engineers continue to investigate.
      Posted Oct 28, 2016 - 11:37 PDT
      Investigating
      We are seeing sporadic HTTP 404 errors in response to GET requests to /Messages resource when querying message logs. Incoming and outgoing message processing not affected. Our engineers are investigating.
      Posted Oct 28, 2016 - 10:52 PDT
      This incident affected: DEVELOPER TOOLS (REST API).