We have started to observe a recovery in call failures and dialing delays to the Movistar network in Venezuela. We will continue to monitor the situation to ensure full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 14, 2025 - 17:12 PDT
Investigating
Our team is still investigating an issue causing call failures and dialing delays to Movistar Network in Venezuela. We are actively working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Jul 14, 2025 - 13:43 PDT
Monitoring
We have started to observe a recovery in call failures and dialing delays to the Movistar network in Venezuela. We will continue to monitor the situation to ensure full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 14, 2025 - 11:46 PDT
Update
Our team is still investigating an issue causing call failures and dialing delays to Movistar Network in Venezuela. We are actively working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Jul 14, 2025 - 10:16 PDT
Update
Our team is still investigating an issue causing call failures and dialing delays to Movistar Network in Venezuela. We are actively working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 14, 2025 - 08:16 PDT
Investigating
Our team is investigating an issue causing call failures and dialing delays to Movistar Network in Venezuela. We are actively working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 14, 2025 - 07:16 PDT
This incident affects: CARRIER NETWORK (Voice, Latin America).