Flex Insights HR is now seeing a recovery regarding the delayed data loads to GoodData workspaces. Users should start seeing up-to-date information in the portal. The incident has now been resolved.
Posted May 01, 2026 - 21:16 PDT
Update
Flex Insights HR is still observing delayed data loads to Gooddata workspaces. The team is actively working with vendor Gooddata. WhiIe the GoodData portal UI remains functional, some users may encounter outdated or stale data in the interim. We will update you with in next 2 hour or as soon as there is an update.
Posted May 01, 2026 - 19:19 PDT
Investigating
Flex Insights HR is observing delayed data loads to Gooddata workspaces. The team is actively working with vendor Good data. WhiIe the GoodData portal UI remains functional, some users may encounter outdated or stale data in the interim. We will update you with in next 1 hour or as soon as there is an update.