Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      A2P 10DLC Campaign Vetting Delays
      Incident Report for Twilio
      Resolved
      Since January 26, 2023, the A2P vetting registration process has required an additional manual verification step, and this additional step is completed by an external third party. Customers are still able to submit new campaign requests and resubmit previous rejected ones; however, this manual verification process is experiencing a high volume of requests, so it is expected that customers will continue to face delays while vetting 10DLC campaigns.

      Twilio will continue to work with the third party agency to expedite and improve verification processes delays. However, since reviews are expected to take longer from now on due this additional verification step, this incident will be closed. If you need further information about your campaign registration, please contact support for further assistance.
      Posted Mar 29, 2023 - 10:43 PDT
      Update
      We continue to face delays while vetting 10DLC campaigns. A third party agency is reviewing campaigns manually and due to the high volume of requests, a queue has built up. Customers are able to submit their Campaign requests. However, reviews are expected to take longer. Twilio continues to escalate the situation and work with the provider to help expedite this process. We will provide updates as soon as more information becomes available.
      Posted Mar 03, 2023 - 06:31 PST
      Update
      We continue to face delays while vetting 10DLC campaigns. A 3rd party agency is reviewing campaigns manually and due to the high volume of requests, a queue has built up. Campaign reviews are expected to take over 15 business days approximately until the situation is resolved. Twilio is working with the provider to help expedite this process. We will provide another update on 03/03/2023 at 10:45 am Pacific Time or as soon as more information becomes available.
      Posted Feb 24, 2023 - 07:56 PST
      Update
      We continue to face delays while vetting 10DLC campaigns. A 3rd party agency is reviewing campaigns manually and due to the high volume of requests, a queue has built up. Campaign reviews are expected to take over 15 business days approximately until the situation is resolved. Twilio is working with the provider to help expedite this process. We will provide another update every 7 days. Next update will be provided on 02/24/2023 at 10:45 am Pacific Time or as soon as more information becomes available.
      Posted Feb 17, 2023 - 10:48 PST
      Update
      We continue to face delays while vetting 10DLC campaigns. A 3rd party agency is reviewing campaigns manually and due to the high volume of requests, a queue has built up. Campaign reviews are expected to take over 7 days until the situation is resolved. Twilio is working with the provider to help expedite this process. We expect to provide another update in next 24 hours or as soon as more information becomes available.
      Posted Feb 16, 2023 - 23:35 PST
      Update
      We continue to face delays while vetting 10DLC campaigns. A 3rd party agency is reviewing campaigns manually and due to the high volume of requests, a queue has built up. Campaign reviews are expected to take over 7 days until the situation is resolved. Twilio is working with the provider to help expedite this process. We expect to provide another update in next 24 hours or as soon as more information becomes available.
      Posted Feb 15, 2023 - 23:37 PST
      Update
      We continue to face delays while vetting 10DLC campaigns. A 3rd party agency is reviewing campaigns manually and due to the high volume of requests, a queue has built up. Campaign reviews are expected to take over 7 days until the situation is resolved. Twilio is working with the provider to help expedite this process. We expect to provide another update in next 24 hours or as soon as more information becomes available.
      Posted Feb 14, 2023 - 23:50 PST
      Update
      We continue to face delays while vetting 10DLC campaigns. A 3rd party agency is reviewing campaigns manually and due to the high volume of requests, a queue has built up. Campaign reviews are expected to take over 7 days until the situation is resolved. Twilio is working with the provider to help expedite this process. We expect to provide another update in next 24 hours or as soon as more information becomes available.
      Posted Feb 13, 2023 - 23:50 PST
      Update
      We continue to face delays while vetting 10DLC campaigns. A 3rd party agency is reviewing campaigns manually and due to the high volume of requests, a queue has built up. Campaign reviews are expected to take over 7 days until the situation is resolved. Twilio is working with the provider to help expedite this process. We expect to provide another update in next 24 hours or as soon as more information becomes available.
      Posted Feb 12, 2023 - 23:50 PST
      Update
      We continue to face delays while vetting 10DLC campaigns. A 3rd party agency is reviewing campaigns manually and due to the high volume of requests, a queue has built up. Campaign reviews are expected to take over 7 days until the situation is resolved. Twilio is working with the provider to help expedite this process. We expect to provide another update in next 24 hours or as soon as more information becomes available.
      Posted Feb 11, 2023 - 23:58 PST
      Update
      We are currently facing delays while vetting 10DLC campaigns. A 3rd party agency is reviewing campaigns manually and due to the high volume of requests, a queue has built up. Campaign reviews are expected to take over 7 days until the situation is resolved. Twilio is working with the provider to help expedite this process. We expect to provide another update in next 24 hours or as soon as more information becomes available.
      Posted Feb 10, 2023 - 23:58 PST
      Update
      We are currently facing delays while vetting 10DLC campaigns. A 3rd party agency is reviewing campaigns manually and due to the high volume of requests, a queue has built up. Campaign reviews are expected to take over 7 days until the situation is resolved. Twilio is working with the provider to help expedite this process. We expect to provide another update in next 24 hours or as soon as more information becomes available.
      Posted Feb 09, 2023 - 23:58 PST
      Update
      We are continuing to investigate this issue.
      Posted Feb 09, 2023 - 00:00 PST
      Update
      We are currently facing delays while vetting 10DLC campaigns. A 3rd party agency is reviewing campaigns manually and due to the high volume of requests, a queue has built up. Campaign reviews are expected to take over 7 days until the situation is resolved. Twilio is working with the provider to help expedite this process. We expect to provide another update in next 24 hours or as soon as more information becomes available.
      Posted Feb 08, 2023 - 23:57 PST
      Update
      We are currently facing delays while vetting 10DLC campaigns. A 3rd party agency is reviewing campaigns manually and due to the high volume of requests, a queue has built up. Campaign reviews are expected to take over 7 days until the situation is resolved. Twilio is working with the provider to help expedite this process. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Feb 08, 2023 - 11:50 PST
      Investigating
      We've become aware of a potential issue with A2P 10DLC campaign reviews, facing delays due to high volume. Our engineering team has been alerted and is actively investigating. We will update as soon as we have additional information.
      Posted Feb 08, 2023 - 11:34 PST
      This incident affected: PROGRAMMABLE MESSAGING (SMS).