Event Streams delivery latency continue to be at normal levels, our engineers will continue to monitor. We will keep monitoring the service and we expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Jul 14, 2025 - 12:42 PDT
Monitoring
Event Streams delivery latency continue to be at normal levels, our engineers will continue to monitor. We will keep monitoring the service and we expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 14, 2025 - 10:44 PDT
Update
Our engineers confirmed they are observing the Event Streams delivery latency back into normal levels. We will keep monitoring the service and we expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Jul 14, 2025 - 09:56 PDT
Investigating
Our engineers are investigating an issue with Event Streams by which events are being delivered with increased latency. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 14, 2025 - 08:30 PDT
This incident affects: DEVELOPER TOOLS (Event Streams).