Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Issue with Credit Cards Processing
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Sep 17, 2019 - 02:35 PDT
      Update
      We are continuing to monitor our billing system as our systems recover. Data in all impacted accounts will be corrected.
      Posted Sep 16, 2019 - 21:16 PDT
      Monitoring
      Our engineers have identified and resolved the billing issue. Any accounts impacted during this time will be corrected.
      Posted Sep 16, 2019 - 17:34 PDT
      Update
      We are continuing to investigate an issue in our billing system that is causing errors when automatically recharging credit cards or upgrading trial accounts.
      Posted Sep 16, 2019 - 16:43 PDT
      Investigating
      We are currently experiencing issues in our billing system impacting trial upgrades and account recharging.
      Posted Sep 16, 2019 - 16:11 PDT
      This incident affected: TWILIO PLATFORM (Billing).