Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      DNS Failures Impacting Twilio APIs and Twilio Websites
      Incident Report for Twilio
      Resolved
      We are seeing full recovery for the subset of Twilio products that were degraded for 6 minutes between 11:37AM and 11:43AM Pacific Time on 10/29/2020. This issue has been resolved.
      Posted Oct 29, 2020 - 15:48 PDT
      Update
      A subset of Twilio products were degraded for 6 minutes between 11:37AM and 11:43AM Pacific Time on 10/29/2020. During this period of time customers may have experienced unavailability of Twilio’s API and websites. We are still seeing impact to a subset of Flex services. Please clear/refresh your cache and DNS. We will continue to monitor and provide another update in 1 hour.
      Posted Oct 29, 2020 - 15:35 PDT
      Update
      A subset of Twilio products were degraded for 6 minutes between 11:37AM and 11:43AM Pacific Time on 10/29/2020. During this period of time customers may have experienced unavailability of Twilio’s API and websites. We are still seeing impact to a subset of Flex services. Please clear/refresh your cache and DNS. We will continue to monitor and provide another update in 30 minutes.
      Posted Oct 29, 2020 - 15:06 PDT
      Update
      A subset of Twilio products were degraded for 6 minutes between 11:37AM and 11:43AM Pacific Time on 10/29/2020. During this period of time customers may have experienced unavailability of Twilio’s API and websites. We are still seeing impact to a subset of Flex services. Please clear/refresh your cache and DNS. We will continue to monitor and provide another update in 30 minutes.
      Posted Oct 29, 2020 - 14:37 PDT
      Update
      We are continuing to monitor for any further issues.
      Posted Oct 29, 2020 - 13:10 PDT
      Update
      A subset of Twilio products were degraded for 6 minutes between 11:37AM and 11:43 Pacific Time on 10/29/2020. During this period of time customers may have experienced unavailability of Twilio’s API and websites. We are still seeing impact to a subset of Voice services. Please clear/refresh your cache and DNS. We will continue to monitor until this has been fully resolved.
      Posted Oct 29, 2020 - 13:08 PDT
      Monitoring
      A subset of Twilio products were degraded for 6 minutes between 11:37AM and 11:43 Pacific Time on 10/29/2020. During this period of time customers may have experienced unavailability of Twilio’s API and websites. If you are still experiencing errors, please clear/refresh your cache. The issue has now been resolved.
      Posted Oct 29, 2020 - 12:28 PDT
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Oct 29, 2020 - 11:49 PDT
      This incident affected: FLEX (TaskRouter, Flex Application Platform, Flex Insights), DEVELOPER TOOLS (Console, REST API), SERVERLESS (Studio), ACCOUNT SECURITY (Verify, Lookup), PROGRAMMABLE VIDEO (Compositions), PROGRAMMABLE VOICE (Recording), PROGRAMMABLE CHAT, and PROGRAMMABLE MESSAGING (Notify, Conversations).