Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Caller ID verification partial failure
Incident Report for Twilio
Resolved
Caller ID verification is working normally now. The incident has been resolved.
Posted Feb 25, 2020 - 08:56 PST
Monitoring
Caller Id verification is stable now and verifications calls are completing normally, our engineers are monitoring the case at the moment and we will post more updates once we confirm the issue is completely resolved.
Posted Feb 25, 2020 - 07:37 PST
Update
Our engineering team is still investigating the issue. The failures are intermittent now. We will share more information as soon as they become available.
Posted Feb 25, 2020 - 06:00 PST
Investigating
We are experiencing some issues with caller ID verification through console and API, our engineers are working on the issue and we will provide an update as soon as they become available.
Posted Feb 25, 2020 - 04:31 PST
This incident affected: TWILIO PLATFORM (Console).