We are no longer experiencing SMS Delivery Delays and Failures to MTN in Guinea-Bissau. This incident has been resolved.
Posted May 24, 2025 - 18:37 PDT
Monitoring
We are observing successful SMS delivery to MTN in Guinea-Bissau. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted May 24, 2025 - 16:41 PDT
Update
We are continuing to experience SMS Delivery Delays and Failures to MTN in Guinea-Bissau. Our engineers are investigating, and we will provide another update in 16 hours or as soon as we have more information.
Posted May 24, 2025 - 07:04 PDT
Update
We are continuing to experience SMS Delivery Delays and Failures to MTN in Guinea-Bissau. Our engineers are investigating, and we will provide another update in 8 hours or as soon as we have more information.
Posted May 23, 2025 - 23:04 PDT
Update
We are continuing to experience SMS Delivery Delays and Failures to MTN in Guinea-Bissau. Our engineers are investigating, and we will provide another update in 4 hours or as soon as we have more information.
Posted May 23, 2025 - 20:08 PDT
Update
We are continuing to experience SMS Delivery Delays and Failures to MTN in Guinea-Bissau. Our engineers are investigating, and we will provide another update in 4 hours or as soon as we have more information.
Posted May 23, 2025 - 19:04 PDT
Update
We are continuing to experience SMS Delivery Delays and Failures to MTN in Guinea-Bissau. Our engineers are investigating, and we will provide another update in 2 hours or as soon as we have more information.
Posted May 23, 2025 - 17:04 PDT
Update
We are experiencing SMS Delivery Delays and Failures to MTN in Guinea-Bissau. Our engineers are investigating, and we will provide another update in 1 hour or as soon as we have more information.
Posted May 23, 2025 - 16:06 PDT
Investigating
Our monitoring systems have detected a potential issue with SMS Delivery Delays and Failures to MTN in Guinea-Bissau. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted May 23, 2025 - 16:03 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).