Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Retroactive: Flex and Task Router 5xx Errors Impacting Voice Traffic

        Incident Report for Twilio

        Resolved

        Flex and Task Router 5xx Errors Impacting Voice Traffic was degraded for 2 minutes between 5:52 PM and 5:54 PM PST Pacific Time on 04/22/2025. During this period of time customers may have experienced some issues with voice traffic. The issue has now been resolved.
        Posted Apr 22, 2025 - 18:15 PDT

        Update

        Our engineers have identified a few hundred 5xx errors due to timeouts with datastore between 5:52pm PST and 5:54pm PST. The errors have subsided and no further impact is being observed.
        Posted Apr 22, 2025 - 18:05 PDT

        Monitoring

        Our engineers are currently investigating the customer impact of a retroactive issue with a short burst of 5xx errors impacted Flex and Task Router Voice traffic. We will follow up and provide customer impact details within 2 hours.
        Posted Apr 22, 2025 - 18:02 PDT