Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to T-Mobile Network in the US
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays when sending to T-Mobile Network in the US on Twilio Short Codes and Toll-Free numbers. This incident has been resolved.
Posted Nov 18, 2020 - 07:22 PST
Update
We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 18, 2020 - 06:52 PST
Monitoring
We are observing recovery in delivery delays when sending to T-Mobile network in the US and will continue monitoring the service to ensure a full recovery. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Nov 18, 2020 - 04:52 PST
Update
We continue to work with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Nov 18, 2020 - 01:49 PST
Update
We are still experiencing delays in SMS Toll-Free and SMS Shortcode delivery to the T-Mobile network in the US. Our engineers are working with our carrier partners to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 17, 2020 - 23:48 PST
Update
We are continuing to investigate this issue.
Posted Nov 17, 2020 - 22:49 PST
Update
We are experiencing delays in SMS Toll-Free and SMS Shortcode delivery to the T-Mobile network in the US. Our engineers are working with our carrier partners to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 17, 2020 - 22:48 PST
Investigating
Our monitoring systems have detected a potential issue with SMS to US and CA Toll-Free Number to T-Mobile. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Nov 17, 2020 - 22:32 PST
This incident affected: CARRIER NETWORK (SMS Short Code, North America, SMS Toll-Free, North America, SMS Delivery Notifications & Status Callbacks).