Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS delivery delays from some US Short Codes
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 17, 2019 - 21:08 PDT
Monitoring
The issue has been resolved. All MMS sent from US Short Codes are now being delivered successfully, and all Message Status Callbacks are being received. We will continue to monitor closely for the next 30 minutes
Posted 3 months ago. Apr 17, 2019 - 20:20 PDT
Update
We are currently seeing improvements in the delivery of MMS to most US wireless networks from Twilio's US short codes. There are still delays in receiving Message Status Callbacks when sending MMS from a subset of US short codes. We continue to work with our carrier partner to fully resolve the issue and will update as information becomes available.
Posted 3 months ago. Apr 17, 2019 - 19:32 PDT
Investigating
We are currently observing outbound delivery delays and delays in receiving Message Status Callbacks when sending MMS from a subset of Twilio US Short Codes. We are working with our carrier partner to resolve the issue and will update as information becomes available.
Posted 3 months ago. Apr 17, 2019 - 13:05 PDT
This incident affected: CARRIER NETWORK (MMS Short Code, North America).