Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Media Recordings - High Latency and Errors While Fetching Voice Recordings
Incident Report for Twilio
Resolved
We are no longer experiencing High Latency and Errors While Fetching Voice Recordings. This Incident has been resolved and Voice Recordings are being fetched normally at this time.
Posted Feb 20, 2021 - 21:51 PST
Monitoring
We were experiencing High Latency and Errors While Fetching Voice Recordings for the last 30 minutes. Our Engineering teams are working on this and we see the service is recovering now. We will continue to monitor the performance. We expect to provide another update in 30 minutes or as soon as we have more details.
Posted Feb 20, 2021 - 21:46 PST
This incident affected: PROGRAMMABLE VOICE (Recording).