Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Failures and Delays on Orange in Israel
      Incident Report for Twilio
      Resolved
      We are no longer seeing delivery failures and delays for SMS sending to Orange in Israel. This incident has been resolved.
      Posted Mar 17, 2020 - 21:41 PDT
      Monitoring
      We are seeing signs of recovery in SMS delivery to Orange in Israel. We will continue to monitor and provide an update as soon as we have additional information.
      Posted Mar 17, 2020 - 21:12 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Mar 17, 2020 - 19:31 PDT
      Investigating
      We are experiencing delivery failures and delays for SMS sending to the Orange in Israel. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Mar 17, 2020 - 18:13 PDT