Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Agents unable to log into Flex
Incident Report for Twilio
Resolved
Flex and TaskRouter are operating normally at this time.
Posted 12 days ago. Oct 08, 2019 - 15:40 PDT
Monitoring
We are now seeing full recovery for TaskRouter and Flex clients. Customers who are experiencing issues should reload the webpage which runs Flex and/or the TaskRouter JavaScript SDK. We are continuing to monitor the issue.
Posted 12 days ago. Oct 08, 2019 - 15:19 PDT
Update
Some Flex and TaskRouter agents are now able to connect and receive task assignments, but Twilio engineering is still seeing some errors and recovery is not complete. Some customers may still see intermittent problems receiving tasks from Flex / TaskRouter, and we are continuing to work to resolve these issues.
Posted 12 days ago. Oct 08, 2019 - 15:06 PDT
Update
We are continuing to work on a fix for this issue.
Posted 12 days ago. Oct 08, 2019 - 14:47 PDT
Identified
Our engineering team has identified a fault in the TaskRouter database that is responsible for delivering tasks to TaskRouter / Flex agents. We are making a change to address the issue now and will have an update shortly.
Posted 12 days ago. Oct 08, 2019 - 14:24 PDT
Investigating
Our engineering team is investigating an issue with our flex product. Agents seem to be unable to log in. We will provide another update shortly.
Posted 12 days ago. Oct 08, 2019 - 14:07 PDT
This incident affected: CONTACT CENTER (TaskRouter, Flex).