Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS/SMS Delivery Report Delays for SMPP Customers on Multiple US Carriers
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery report delays for SMS and MMS across multiple US Carriers. This incident has been resolved.
      Posted Jun 05, 2023 - 15:50 PDT
      Monitoring
      We are observing recovery in delivery report delays for both SMS and MMS on multiple US Carriers. We will continue monitoring the service to ensure a full recovery. We will provide another update in 30 minutes or as soon as more information becomes available.
      Posted Jun 05, 2023 - 15:29 PDT
      Update
      We are experiencing delays in receiving message delivery reports for both SMS and MMS on multiple US Carriers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jun 05, 2023 - 15:16 PDT
      Investigating
      We are experiencing delays in receiving message delivery reports. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Jun 05, 2023 - 15:08 PDT
      This incident affected: PROGRAMMABLE MESSAGING (MMS, SMS).