Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound and outbound MMS delays to Sprint short codes
Incident Report for Twilio
Resolved
The MMS delivery delay issue on Sprint US handsets is now resolved and we are observing full and stable message delivery.
Posted 5 months ago. Oct 04, 2018 - 20:05 PDT
Monitoring
We are seeing recovery of inbound and outbound MMS delivery to Sprint via Short Codes. Our engineering team will continue to monitor the service.
Posted 5 months ago. Oct 04, 2018 - 18:03 PDT
Investigating
We are experiencing delays for a subset of Inbound and Outbound MMS to Sprint Short Code. We are working with our carrier partner to resolve the issue.
Posted 5 months ago. Oct 04, 2018 - 12:45 PDT
This incident affected: PROGRAMMABLE MESSAGING (MMS).