Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Retroactive - Message Delivery Delays to Verizon Handsets in the US
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 8 months ago. May 30, 2018 - 13:07 PDT
Investigating
We experienced delays in message delivery to Verizon handsets in the US between 11:54am and 12:20pm PDT. Messages were delayed up to 5 minutes. All systems have recovered and messages are being delivered without delay since 12:20 pm.
Posted 8 months ago. May 30, 2018 - 13:05 PDT
This incident affected: PROGRAMMABLE MESSAGING (SMS).